WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 21 months ago

#24793 closed enhancement (duplicate)

When WP is installed in subfolder, "preview post" does not link correctly

Reported by: julie-edwards Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: General Keywords: close
Focuses: Cc:

Description

Link to my site: http://zephir.seattlecentral.edu/~jdodso06/dev/

I installed WP(v3.5.2) in a subfolder called wp-system and redirected from my index page via:
require('./wp-system/wp-blog-header.php');

My admin page is at http://zephir.seattlecentral.edu/~jdodso06/dev/wp-system/wp-admin/

This is working correctly except when I attempt to view post or view page from within the admin dashboard, it tries to link to the page with the /wp-sytem in the path

i.e.
http://zephir.seattlecentral.edu/~jdodso06/dev/wp-system/?p=1

rather than
http://zephir.seattlecentral.edu/~jdodso06/dev/?p=1

I believe this should correctly find the actual location of the post.

Change History (3)

comment:2 @JustinSainton22 months ago

  • Keywords close added
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13779.

comment:3 @dd3221 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.