WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#24836 closed defect (bug) (wontfix)

WordPress database setup error does not preserve input with "try again" when no-js

Reported by: hakre Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Upgrade/Install Keywords: ux-feedback
Focuses: Cc:

Description

When setting up Wordpress and entering the database credentials and the setup communicates an error condition back it offers as well a "Try again" button.

Pressing that button does *not* try again. It offers the input form with all user-entered values deleted.

Instead of deleting those values, the previous user-entered data should be given after pressing that "Try again" button.

Attachments (4)

wp-24836-screenshot-001-entering-data.png (62.2 KB) - added by hakre 9 months ago.
wp-24836-screenshot-002-showing-the-error.png (52.8 KB) - added by hakre 9 months ago.
wp-24836-screenshot-003-trying-again.png (60.5 KB) - added by hakre 9 months ago.
wp-24836-screenshot-004-workflow.png (146.6 KB) - added by hakre 9 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 follow-ups: SergeyBiryukov9 months ago

  • Component changed from Administration to Upgrade/Install
  • Keywords reporter-feedback added; ux-feedback removed

Could not reproduce.

The button onclick event is history.go(-1), so clicking the button is the same as clicking browser's Back button: tags/3.5.2/wp-admin/setup-config.php#L169.

Were you testing with JavaScript or browser cache disabled, perhaps?

comment:2 in reply to: ↑ 1 hakre9 months ago

Replying to SergeyBiryukov:

The button onclick event is history.go(-1), so clicking the button is the same as clicking browser's Back button: tags/3.5.2/wp-admin/setup-config.php#L169.

Were you testing with JavaScript or browser cache disabled, perhaps?

Obviously no client-side ECMA scripting enabled, yes.

See as well


Screenshots were taken while reproducing the issue for the report.

Version 3, edited 9 months ago by hakre (previous) (next) (diff)

comment:3 in reply to: ↑ 1 hakre9 months ago

Replying to SergeyBiryukov:

@SergeyBiryukov, did that answer your feedback question?

comment:4 hakre9 months ago

  • Keywords ux-feedback added; reporter-feedback removed

comment:5 aaronholbrook9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I also could not reproduce using exact same steps. It shows original inputs after hitting 'Try Again'

comment:6 dd328 months ago

  • Milestone Awaiting Review deleted

comment:7 ocean908 months ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Wordpress database setup error does not preserve input with "try again" to WordPress database setup error does not preserve input with "try again" when no-js
  • Version changed from 3.5.2 to 3.4

It shows original inputs after hitting 'Try Again'

And that's the bug hakre mentions here.

The back button was introduced in[20661].

comment:8 dd328 months ago

I do think this is a invalid/wontfix issue. At the least, a now-duplicate of #24982

Initial bug is that, It doesn't try again, it offers the form pre-filled again.

It's browser's that control if the form is re-filled, the Try Again button is the same as the back button, Some clients will re-fill the content, some will clear it (may depend on HTTPS, and other factors).

comment:9 follow-up: nacin8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

This bug is specific to "when no-js". WONTFIX.

comment:10 in reply to: ↑ 9 hakre8 months ago

Replying to nacin:

This bug is specific to "when no-js". WONTFIX.

Err what?

Note: See TracTickets for help on using tickets.