WordPress.org

Make WordPress Core

#24841 closed defect (bug) (duplicate)

Cannot add two similar tags (example: "Google" and "Google+") within the same post.

Reported by: kaiby Owned by:
Milestone: Priority: normal
Severity: major Version: 3.5.2
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Summary

When adding more than 1 tag with similar names to a post, Wordpress will strip out the second tag because of its similar naming convention. This becomes an issue when each tag represents a unique idea. This did not used to happen before 3.5.x.

Reproducing This Issue

In a fresh Wordpress install, create a post and add "Google" and "Google+" as tags. When saving/publishing/updating the post, Wordpress will only add "Google", but not "Google+".

Change History (8)

comment:1 @kaiby22 months ago

  • Cc ohkaiby@… added

comment:2 @SergeyBiryukov22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16567.

comment:3 @SergeyBiryukov22 months ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not an exact duplicate actually, just related. I thought the patch on #16567 handles this, but it doesn't.

comment:5 @kaiby22 months ago

Thanks for the hack, will see if that solves the issue while we wait for an official fix.

comment:7 @kaiby22 months ago

The hack by wonderboymusic works. Thanks wonderboy, what is the secret of your power?

comment:8 @wonderboymusic21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

For sake of cleaning up tickets, #17689 addresses the issue

Note: See TracTickets for help on using tickets.