WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 8 months ago

#24845 closed defect (bug) (fixed)

Upgrade Network page continues to say Database Upgrade Required

Reported by: andrejcarter Owned by: nacin
Milestone: 3.6.1 Priority: normal
Severity: normal Version: 3.6
Component: Network Admin Keywords: has-patch commit
Focuses: multisite Cc:

Description

I'm running 3.6RC2 on 2 separate installations on separate servers. Both with Multisite Subdomains active. On both the /wp-admin/network/upgrade.php page says "Database Upgrade Required" despite running the Upgrade Network process several times. The sites appear to be working normally.

Attachments (2)

24845.diff (782 bytes) - added by duck_ 8 months ago.
24845.2.diff (750 bytes) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (18)

comment:1 follow-up: nacin9 months ago

Works for me and for ocean90. Possibly a persistent caching issue?

comment:2 hallsofmontezuma9 months ago

FWIW I'm seeing the same thing. I'm using 3.6 + domain mapping plugin, and I can't find anything wrong with the actual sites.

edit - nevermind, talked to Nacin and mine is a different issue

Last edited 9 months ago by hallsofmontezuma (previous) (diff)

comment:3 in reply to: ↑ 1 andrejcarter8 months ago

Replying to nacin:

Works for me and for ocean90. Possibly a persistent caching issue?

We cleared everything we could think of so I don't think so, but I'm by no means an expert. Since the opening the ticket I upgraded 2 additional installation and get the same message. I'm also using a domain mapping plugin (WordPress MU Domain Mapping). I disabled all plugins and re-ran the upgrade script and nothing changed. I haven't noticed any issues using any of the sites showing the error.

comment:4 extremulus8 months ago

  • Cc extremulus added

I am experiencing this as well and exactly as it is described by andrecarter

comment:5 nacin8 months ago

I am going to guess that this is limited to the Domain Mapping plugin.

comment:6 jeremyfelt8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I've had this same issue with MU Domain Mapping in the past.

comment:7 Ipstenu8 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopening - I reproduced this on a clean Multisite (locally) with no plugins, nothing, going back to WP 3.3

Looking at the code, I see this at the top:

$action = isset($_GET['action']) ? $_GET['action'] : 'show';

And then the show is set to exactly the message we're seeing. Plus I don't see any other fall back like "No update required"

comment:8 SergeyBiryukov8 months ago

  • Keywords needs-patch added
  • Milestone set to 3.7

Indeed, wp-admin/network/upgrade.php always says "Database Upgrade Required". Introduced in [23619].

comment:9 nacin8 months ago

  • Milestone changed from 3.7 to 3.6.1

I misread the report and thought it was about the dashboard notification bar — turns out this is the same issue that hallsofmontezuma reported to me privately.

Yes, upgrade.php always says "Database Upgrade Required". I guess we need to tweak [23619]. We could consider removing the <h3> for 3.6.1, though we can probably just fix this up in 3.7 — you only land on this page if you need to run an update; otherwise, you'd have to go to it on your own.

comment:10 Ipstenu8 months ago

Given that there is a link to the page that is more readily apparent on the network admin, it makes sense that people are visiting this on their own. Accidentally, yes, but if a page has a link to it on the admin sidebar, they will visit :)

duck_8 months ago

comment:11 duck_8 months ago

  • Keywords has-patch added; needs-patch removed

comment:12 nacin8 months ago

  • Keywords commit added

comment:13 nacin8 months ago

In 25191:

Hide 'Database Upgrade Required' on admin/network/upgrade.php when you are not being asked to upgrade, to prevent confusion.

props duck_.
see #24845. see #23540.

comment:14 nacin8 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from reopened to closed

In 25192:

Hide 'Database Upgrade Required' on admin/network/upgrade.php when you are not being asked to upgrade, to prevent confusion.

Merges [25191] to the 3.6 branch.

props duck_.
fixes #24845.

SergeyBiryukov8 months ago

comment:15 SergeyBiryukov8 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The original intent of #23540 was to make it clear that it's a database upgrade and not a core update.

[25191] still doesn't make it clear in case the header is not displayed. I'd suggest 24845.2.diff for 3.7, there should be "database" in there somewhere :)

comment:16 nacin8 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 25237:

Clarify a database upgrade string, for 3.7.

props SergeyBiryukov.
fixes #24845.

Note: See TracTickets for help on using tickets.