WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#24866 closed enhancement (wontfix)

Multi Site Plugins Add New / Editor for Super Admins

Reported by: mordauk Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.2
Component: Plugins Keywords: has-patch close
Focuses: ui, administration, multisite Cc:

Description

I find it really silly that network administrators do not get the "Add New" or "Editor" links under the Plugins menu in sub sites of a network install.

This patch enables the links for super admins.

Attachments (3)

plugins-add-new.patch (677 bytes) - added by mordauk 7 years ago.
24866.patch (722 bytes) - added by mordauk 7 years ago.
24866-adminbar.diff (948 bytes) - added by sillybean 7 years ago.
Add themes and plugins links to the Network section of the admin bar

Download all attachments as: .zip

Change History (29)

@mordauk
7 years ago

#1 @mordauk
7 years ago

24866.patch checks for install_plugins as well, just in case someone has modified default roles and created a role that can manage network but not install plugins.

#2 @sillybean
7 years ago

  • Cc steph@… added

#3 @sc0ttkclark
7 years ago

+1 on this, this bugs the trac out of me

#4 @sc0ttkclark
7 years ago

  • Cc lol@… added

#5 @Japh
7 years ago

  • Cc japh@… added

#6 follow-up: @nacin
7 years ago

I think part of the issue — and this applies to themes too — is that people need to be aware that what they are doing has global, network-wide implications. The network admin aimed for a clear separation of concerns, and I'm not sure there is a huge reason to deviate from that.

#7 in reply to: ↑ 6 @mordauk
7 years ago

Replying to nacin:

I think part of the issue — and this applies to themes too — is that people need to be aware that what they are doing has global, network-wide implications. The network admin aimed for a clear separation of concerns, and I'm not sure there is a huge reason to deviate from that.

I think the words "Network Acivate" after a plugin is installed achieves that.

#8 @sillybean
7 years ago

That's a good point. Maybe it would be better to add "manage network plugins" and themes to the Network section of the admin bar, near My Sites, instead of restoring the original menu links.

@sillybean
7 years ago

Add themes and plugins links to the Network section of the admin bar

#9 follow-up: @sillybean
7 years ago

Patch to add Themes and Plugins to the admin bar, under Network.

#10 in reply to: ↑ 9 @SergeyBiryukov
7 years ago

Replying to sillybean:

Patch to add Themes and Plugins to the admin bar, under Network.

Related: #21674

#11 @DrewAPicture
7 years ago

  • Cc xoodrew@… added

#12 @sillybean
7 years ago

  • Keywords close added

Fixed along with #21674?

#13 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Sure, closing this in lieu of #21674.

#14 follow-up: @DrewAPicture
7 years ago

  • Milestone set to Awaiting Review
  • Resolution wontfix deleted
  • Status changed from closed to reopened

[25120] handled @sillybean's proposed adminbar patch, but didn't address the original intent of this ticket: to consider adding the 'Add New' and 'Editor' links in a sub-site admin menu if the current user is a super admin.

#15 in reply to: ↑ 14 @nacin
7 years ago

Replying to DrewAPicture:

[25120] handled @sillybean's proposed adminbar patch, but didn't address the original intent of this ticket: to consider adding the 'Add New' and 'Editor' links in a sub-site admin menu if the current user is a super admin.

sillybean's point was that if the original menu links are not desirable, [25120] is a suitable replacement — at least for now, to allow for reviewing this later.

The network admin was designed to separate these concerns and I wontfixed this based on that logic. While I'm open to discussion, I think [25120] is enough for 3.7 if people really just want a shortcut.

#16 follow-up: @mordauk
7 years ago

[25120] is certainly a welcomed addition, though I don't think it's an adequate resolution for the original issue here.

While it's true that the network admin menu does provide a short cut to the network plugins page now, the lack of an "Add New" under the main Plugins menu for super admins still seems strange to me. It doesn't seem nearly as intuitive to have to go to the Network menu in order to find the plugins installation page.

Earlier, Nacin mentioned that one of the reasons for not having it is because it's not inherently apparent that installing a plugin does so for the entire network, and I definitely don't disagree with that, but I would argue that it's also not inherently apparent that an admin has to go to the network admin in order to install plugins.

By allowing super admins to access the plugin installer from any site, and in the same location as is standard for non-multi site installs, the plugin install process becomes more intuitive.

I feel that the "Network Active" link provided after installing a plugin is sufficient to alert the admin that the plugin is going to be activated for the entire network.

#17 @Ipstenu
7 years ago

Speaking for the past, when Multisite had all the network admin tools off of the main site, there was a non-insignificant number of people being outright confused as to the differences between activate and network activate. After all, they're on that site! It's for this site!

I feel that while, for power users and experienced admins, this would be fine, it's not something the average WP user (even the average multisite user, who is more advanced than many single instance WP users) would need. Telling them "Network plugins and themes can only be managed by super admins on the Network Panel" forces them to remember what they're doing.

If it's not apparent that the super admin needs to go to the network admin for this sort of thing, then what about a patch to add in an alert/notice? "Super-Admin: To add new plugins, go to the Network Plugin Manager" with a link.

#18 in reply to: ↑ 16 @nacin
7 years ago

Replying to mordauk:

By allowing super admins to access the plugin installer from any site, and in the same location as is standard for non-multi site installs, the plugin install process becomes more intuitive.

I'd pretty strongly argue that A) no, it becomes less intuitive, and B) most users are not managing multiple installs, or frequently going between multisite and non-multisite.

I feel that the "Network Active" link provided after installing a plugin is sufficient to alert the admin that the plugin is going to be activated for the entire network.

I don't. (See also: end of this comment.)

Replying to Ipstenu:

Speaking for the past, when Multisite had all the network admin tools off of the main site, there was a non-insignificant number of people being outright confused as to the differences between activate and network activate. After all, they're on that site! It's for this site!

Yes. I don't want to go back to the days where there wasn't an obvious difference between the network admin and individual site dashboards. I do a ton of network administration (for wordpress.org) and the separation of concerns provides a very clear context for where I am, what I am doing, and what effects I am causing.

If it's not apparent that the super admin needs to go to the network admin for this sort of thing, then what about a patch to add in an alert/notice? "Super-Admin: To add new plugins, go to the Network Plugin Manager" with a link.

Similar to the refrain that with too many options, the user can't find any of them: With too many notices/alerts that act as navigation aids, users won't read any of them. (Also, if you need an alert to function as a navigation aid, then you have larger problems.) We do a basic, not very prominent navigation aid for themes, and could do that for plugins as well, though I would be loathe to add it.

I'm happy to entertain user tests in the area of network administration. But for now, this is still very clearly a wontfix.

#19 @jeremyfelt
6 years ago

  • Component changed from Network Admin to Plugins
  • Focuses administration added

#20 @mordauk
5 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

#21 @obenland
5 years ago

  • Milestone Awaiting Review deleted

#22 @mordauk
5 years ago

For anyone that does want this, here's the plugin: https://wordpress.org/plugins/multi-site-plugins-add-new/

#23 @DrewAPicture
5 years ago

#31659 was marked as a duplicate.

This ticket was mentioned in Slack in #core by drew. View the logs.


5 years ago

#25 @saracannon
5 years ago

  • Focuses ui added

I'd argue these assumptions:

1) The person needing to install a plugin is the Multisite Network Administrator
2) The Multisite Network Administrator is knowledgeable at installing plugins or else they would not be managing multisite.
3) They know that installing a plugin will not network activate it unless they tell it to do so, and that they need to activate installed plugins individually.

Current Scenario:
1) The Multisite Network Administrator is going to install a plugin onto a single site
2) The Network Admin browses to the plugin page on the single site to see if they already have the plugin that just needs to be activated/configured or if there is already a similar plugin there. (aka: "I think jetpack might be already installed. I'll go check and activate it if it is")
3) The Network Admin determines that it needs to install a new plugin.
4) Action: There is no easy way to do this without a lot of hovering and clicking. (... in the admin bar: scroll over "my sites" then "network admin" then click plugins....then finally hit the "Add New" button that is in the same spot where you were in the first place but is there now that you are in the Network Admin section.) Then after install: hover "my sites", then the site name, then click Dashboard because we can't get back to activate the plugin from that menu. then click "plugins" then scroll through the list to find it... then activate.

the last action is seriously a frustrating experience for MS Administrators. I'd argue this suggested fix:

  • Include the "Add New" button on the plugins page within individual installs only when logged in as Network Admin. This will take you to wp-admin/network/plugin-install.php: http://s.sar.ac/image/1B3d3X2W2S1t
  • After install on the Post-Installation-Page (I'm not sure what we call this page): add a menu item link that activates the plugin for individual site where you had previously hit "add new" and return you to that individual site's plugin page so you can make further configurations: http://s.sar.ac/image/1H1Y433R1f2r (I'd probably suggest that the link be the first item rather than the last)

thoughts?

#26 @mordauk
5 years ago

I like that proposal and do feel it adequately addresses the concerns voiced above.

Note: See TracTickets for help on using tickets.