WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#24919 closed defect (bug) (invalid)

Revisions in 3.6: Edit to custom field does not create a revision point.

Reported by: eablokker Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Revisions Keywords: reporter-feedback
Focuses: Cc:

Description

At first I thought my custom field revisions were not being tracked. It turns out they ARE being tracked, BUT no revision point is created for them. It seems only editing the title or content causes a revision point to be created. So if you want a custom field revision to be saved, you ALSO have to edit either the title or content, because that's the only way a revision point would get created.

Change History (9)

comment:1 follow-ups: helen9 months ago

  • Keywords reporter-feedback added

Your custom field revisions are being tracked? Because #20564 (and the way meta is stored) says otherwise.

comment:2 in reply to: ↑ 1 eablokker9 months ago

Replying to helen:

Your custom field revisions are being tracked? Because #20564 (and the way meta is stored) says otherwise.

I don't know what the intended behavior is supposed to be. I assume the intended behavior should be the same as the behavior in 3.5. 3.5 tracks and creates revision points for custom fields. 3.6, for me, is not creating revision points for custom fields, but in the revision.php view, it DOES show comparison changes to custom fields IF there was ALSO a change to the title.

comment:3 in reply to: ↑ 1 eablokker9 months ago

Replying to helen:

Your custom field revisions are being tracked? Because #20564 (and the way meta is stored) says otherwise.

Testing again... it appears that I can see revisions for custom fields on only the current revision compared to the next previous revision. All other revisions before that are not showing any comparison changes on custom fields. Likewise when "compare any two revisions" is checked, and I'm comparing anything other than the current revision with the next previous revision, the changes to custom fields are not visible.

I personally would like to see all custom field revisions tracked, but if the intended behavior is to NOT track custom fields, then it would appear that this is a bug - I shouldn't be able to see any custom field comparisons at all. Somehow I can see them on the current revision.

comment:4 nacin9 months ago

Hi eablokker: There is a filter called _wp_post_revision_fields that allows you to specify additional fields to revision, but it is not easy to use (it is not directly tied to custom fields). There is currently no easy way to track the revisions of custom fields in WordPress, and 3.6 didn't make it any more difficult than 3.5.

Could you take and upload some screenshots of what you're seeing? That would be very helpful to figure out what you are seeing.

comment:5 follow-up: dd329 months ago

It's worth noting that my Revisions Control plugin has some custom meta handling, Is it possible you're using that? (I haven't tested with 3.6 yet, and it hasn't been updated in 2 years, so it's possible it's broken, or was already broken)

comment:6 in reply to: ↑ 5 eablokker9 months ago

Replying to dd32:

It's worth noting that my Revisions Control plugin has some custom meta handling, Is it possible you're using that? (I haven't tested with 3.6 yet, and it hasn't been updated in 2 years, so it's possible it's broken, or was already broken)

Oh, no I'm not using that plugin, but I am using the Advanced Custom Fields plugin. I didn't think that might do some funky stuff to the revision control. I was testing with regular custom fields, not advanced fields, but the plugin is still installed nonetheless. I will have to try again without the plugin.

comment:7 eablokker9 months ago

Okay, my bad. Everything works normally with Advanced Custom Fields plugin disabled. I will report bug to ACF plugin authors.

comment:8 eablokker9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

comment:9 DrewAPicture9 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.