WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#24938 closed enhancement (duplicate)

Consider WP_List_Table public

Reported by: DavidAnderson Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Administration Keywords:
Focuses: Cc:
PR Number:

Description

WP_List_Table is far too nice to be left as private - it's too tempting to use it as a plugin developer. It's less work to just use it's lovely featurse and then do the work of keeping up to date of tracking core changes, than to re-make it for your own plugin.

Therefore I propose changing the hint in class-wp-list-table.php from:

  • @access private

to:

  • @access public

Change History (3)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18449.

#2 @SergeyBiryukov
6 years ago

  • Version changed from trunk to 3.6

This ticket was mentioned in Slack in #core by sergey. View the logs.


2 years ago

Note: See TracTickets for help on using tickets.