WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#24939 closed defect (bug) (duplicate)

Login with a login name consisting of special characters not possible anymore

Reported by: tilmanjo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Users Keywords: reporter-feedback
Focuses: Cc:

Description

I have a website in German. We have a lot of people subscribed to the website (around 2000).
Since one of the latest updates it is not possible for people to login when they have a login name with Umlaute like "Götze", "Müller".

Change History (5)

#1 @SergeyBiryukov
8 years ago

Core only supports strict ASCII usernames, see #5918.

When I try to register as "Götze" on a clean install, I get an error: "This username is invalid because it uses illegal characters. Please enter a valid username."

sanitize_user() function is used for validation: tags/3.6/wp-includes/formatting.php#L885.

The last two changes there were [14428] and [15948], in WordPress 3.0 and 3.1.

Did you use a plugin to allow those usernames?

#2 @SergeyBiryukov
8 years ago

  • Component changed from General to Users
  • Keywords reporter-feedback added

#3 @tilmanjo
8 years ago

The login always worked till I updated yesterday to 3.6

We have a programmed a special registration page and insert the user directly in the database.

#4 @SergeyBiryukov
8 years ago

Could you provide the code you use for the registration page?

#5 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5918.

Note: See TracTickets for help on using tickets.