WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 23 months ago

#24943 closed defect (bug) (fixed)

Twenty Thirteen - broken localization of custom header images

Reported by: pavelevap Owned by: nacin
Milestone: 3.7 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch commit
Focuses: Cc:

Description

Function twentythirteen_custom_header_setup() is probably called before twentythirteen_setup() and they are related to the same after_setup_theme action. So, twentythirteen textdomain is loaded after twentythirteen_custom_header_setup() and that is why localization of 3 strings (Star, Diamond and Circle) for custom header does not work.

See attached patch (works for me).

Attachments (1)

custom-header-localization.patch (516 bytes) - added by pavelevap 2 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 @obenland2 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.7

comment:2 @SergeyBiryukov2 years ago

Confirmed the bug and the fix.

comment:3 @obenland23 months ago

Another reason I like to aggregate all includes at the end of the functions.php file.

Although setting a priority will always work and would not be depended on the chance of the callback being registered at the right time. :)

comment:4 @SergeyBiryukov23 months ago

  • Keywords commit added

comment:5 @nacin23 months ago

Priority is much more reliable than include order.

comment:6 @nacin23 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 25129:

Twenty Thirteen: Ensure custom headers are set up after the localization is initialized.

props pavelevap.
fixes #24943.

Note: See TracTickets for help on using tickets.