WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2496 closed defect (bug) (worksforme)

Windows servers can't delete attached files

Reported by: skeltoac Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.1
Component: Administration Keywords: has-patch 2nd-opinion needs-testing windows
Focuses: Cc:

Attachments (1)

quote-filenames.diff (451 bytes) - added by skeltoac 8 years ago.

Download all attachments as: .zip

Change History (6)

skeltoac8 years ago

comment:1 davidhouse8 years ago

  • Keywords needs-testing windows added

comment:2 matt8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3952]) Allow Windows folks to delete attachements, fixes #2496

comment:3 markjaquith8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reverted in [4409] because this is causing double slashing (as reported by mdawaffe):

mdawaffe: MarkJaquith: _wp_attached_file now looks like /Users/michael/Sites/currentwp/wp-content/uploads/2006/10/gofpromo0342\.jpg in trunk

Need to look for a different solution. add_post_meta() expects non-slashed input.

comment:4 Nazgul7 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I can't reproduce this on trunk anymore. I guess the recent upload changes fixed this?

comment:5 Nazgul7 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.