WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#24985 closed defect (bug) (duplicate)

Custom roles missing from post author dropdown

Reported by: archon810 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Users Keywords:
Focuses: Cc:

Description

We have a site with about 15 active publishing users, and in Wordpress 3.6, the dropdown for post author is now missing people from any custom roles I've defined (Senior Editor and others) using http://wordpress.org/plugins/members, a pretty standard plugin for creating new user roles.

I tried both the Quick Edit and Edit screens.

I'm fairly sure this worked before, though I'm not 100% sure.

Additionally, posting a test post using xmlrpc (via Windows Live Writer) and selecting one of the people in custom roles works fine, so to me this looks like a bug.

Change History (5)

#1 @archon810
6 years ago

  • Cc admin@… added

#2 @rachelbaker
5 years ago

  • Keywords close added
  • Resolution set to wontfix
  • Status changed from new to closed

The Post Author box lists users with a user_meta "user_level" value set to 2 or higher (matching roles of Author or above).

The Members plugin just sets "user_level" value to 0, meaning no matter how many capabilities you give a custom role created, the user level matches the Subscriber role. Ideally the Members plugin should allow you to set a relative user level to appropriately match the custom role you are creating.

This would be within the plugin authors ability to fix, and not WordPress.

#3 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted

#4 @ocean90
4 years ago

  • Keywords close removed
  • Resolution changed from wontfix to duplicate

Duplicate of #16841.

#5 @swissspidy
3 years ago

For anyone stumbling upon this ticket, using add_filter( 'members_remove_old_levels', '__return_false' ); should do the trick when using the Members plugin.

Note: See TracTickets for help on using tickets.