WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#24986 closed defect (bug) (worksforme)

Live Preview not working - displays blank page on WP 3.6 via Firefox 23.0 and IE9

Reported by: neosource Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Customize Keywords:
Focuses: Cc:

Description

Hi,

I just upgraded from 3.5.1 to 3.6 on a new development site (running on http port 8000) with no plugins installed.

When viewing the themes in admin, the live preview feature only displays the sidebar and the rest of the page is blank.

Let me know if you need any more info.

Thanks.

Change History (10)

#1 @alexvorn2
6 years ago

can u view the default themes?

#2 @neosource
6 years ago

No, not even the default themes appear in the preview. I've removed the 3rd party themes, and it didn't make a difference.

The only thing I haven't checked/compared is a fresh 3.6 install.

#3 @alexvorn2
6 years ago

Then I think there might be an error that makes the live preview to be blank.
You can change this define('WP_DEBUG', false); to this define('WP_DEBUG', true); in your wp-config.php file to see what errors are there.

#4 @neosource
6 years ago

  • Summary changed from Live Preview not working - displays blank page on WP 3.6 to Live Preview not working - displays blank page on WP 3.6 via Firefox 23.0 and IE9

#5 @neosource
6 years ago

I did a full fresh install (new database) and am still getting the same result.
I have tried enabling wp_debug & script_debug as well.
I have tried testing it in multiple browsers. It seems to work in Chrome but not in Firefox 23.0 (all plugins disabled) or IE9.

The only error messages that have intermittently appeared are as follows:

apache error_log:

PHP Notice: ob_end_flush() [<a href='ref.outcontrol'>ref.outcontrol</a>]: failed to delete buffer zlib output compression. in /localsite/httpdocs/wp-includes/functions.php on line 2736, referer: http://localsite:8000/wp-admin/index.php

firefox console (not sure if its related though):

Timestamp: 8/08/2013 5:22:12 PM
Error: [Exception... "'Image HTTP->HTTPS redirection to https://secure.gravatar.com/avatar/34d428e35f9cc9b5621049e79d86b4f8?s=16&d=http%3A%2F%2F1.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&r=G' when calling method: [nsIContentPolicy::shouldLoad]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0" data: no]

I hope that helps.

#6 @alexvorn2
6 years ago

can't replicate, maybe you are using an old php version

#7 @neosource
6 years ago

my server setup is:

CentOS 6.4
Linux Kernel 2.6.32-358.6.2.el6.x86_64
Apache 2.2.15
PHP 5.3.3
MySQL 5.1.69

I'll test it on a hosted account and see how that goes...

#8 @Clorith
6 years ago

Using live preview on non-default ports will always be messy (and in most cases, result in a blank screen as described) due to security features in the browsers for iframe implementations, also common when using HTTPS (port 443).

#9 @nacin
5 years ago

  • Component changed from Administration to Appearance

#10 @chriscct7
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Since the bug was reported, no one else has been able to replicate this ticket. Furthermore, the bug in hand is likely caused by browser functionality as mentioned in comment:8. Given the lack of anyone else with or able to replicate this bug in the last 2 years closing as worksforme

Note: See TracTickets for help on using tickets.