WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 4 months ago

#24998 closed enhancement (wontfix)

In-line Login Modal Sizing

Reported by: sewmyheadon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Administration Keywords: has-patch
Focuses: ui Cc:

Description

In WP 3.6 when a session times out, the in-line login modal's height is automagically set, but the width is fixed.

Would like a way to also have the width automagically calculated based on the width of the login form, or a hook/filter we could use to change the sizing.

To reproduce the problem, you simply need to style the login form to be greater than 380px wide and force a session timeout. See attached screenshot.

I've seen this issue on Mac & Linux in Chrome and Firefox and haven't tried on Windows, and it seems to be a core issue; not plugin dependent.

Attachments (2)

custom_login_modal.png (107.9 KB) - added by sewmyheadon 21 months ago.
Custom login modal
24998-filter.diff (1.2 KB) - added by DrewAPicture 21 months ago.
wp_auth_check_width filter

Download all attachments as: .zip

Change History (4)

@sewmyheadon21 months ago

Custom login modal

@DrewAPicture21 months ago

wp_auth_check_width filter

comment:1 @DrewAPicture21 months ago

  • Keywords has-patch 2nd-opinion close added
  • Type changed from defect (bug) to enhancement

Not really sure it's worth the filter just to override the width style, when you can just as easily print an overriding style for #wp-auth-check-wrap #wp-auth-check in the admin header.

Doing something like I did in 24998-filter.diff just seems like overkill for what I'm guessing is a bit of an edge case.

comment:2 @DrewAPicture4 months ago

  • Component changed from General to Administration
  • Focuses ui added
  • Keywords 2nd-opinion close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

No interest in 17 months. Closing as wontfix.

Note: See TracTickets for help on using tickets.