WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#25001 closed defect (bug) (duplicate)

Validate inserted links

Reported by: avryl Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Editor Keywords:
Focuses: Cc:

Description

Inserting a link without http:// in the editor doesn't add that. I've seen lots of people just copy pasting a link over the http:// suggestion causing the link to break.
Why not validate the link and add http:// when there's no protocol?
This would prevent people from adding valid relative urls, but I think using relative urls is a bad idea anyway. Would also solve #11438 for feeds.

Change History (2)

comment:1 SergeyBiryukov8 months ago

  • Component changed from Validation to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18149.

comment:2 avryl8 months ago

Thanks, I didn't see that one.

Note: See TracTickets for help on using tickets.