WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#25004 closed defect (bug) (duplicate)

Content Editor Buttons Cause Side Panel Overlap

Reported by: kwoodfriend Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.6
Component: Editor Keywords:
Focuses: Cc:

Description

There's a issue caused by the entry page's content editor when the following criteria is met:

  1. The entry page is using the 2 column layout.
  2. The "Kitchen sink" has been enabled, showing the editor's second row of buttons.
  3. The window's width is at 1029px or less. Around 1008px, the right panels will overlap the content box.

This problem is exacerbated when a theme or plugin has added any additional buttons to the editor, causing the overlapping to happen at a greater width. This happens until the window is reduced to the 850px break point, when single column layout is force.

I've tested this with both 3.5 and 3.6 (fresh installs) and Chrome v28.0.1500.95. I did not test with other browsers. Widths were gleaned via jQuery(window).width().

A possible option may be to remove the use of a table for the button layout, or force the table, tbody, tr, and td elements to use a display value of block, block, block, inline-block. Other work would be needed, but the latter method would possibly prevent any required markup changes.

A workaround is to set the layout to a single column.

Attachments (1)

Screen Shot 2013-08-09 at 11.38.18 AM.png (193.2 KB) - added by kwoodfriend 8 months ago.
Screenshot of overlapping area

Download all attachments as: .zip

Change History (2)

kwoodfriend8 months ago

Screenshot of overlapping area

comment:1 helen8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23904.

Note: See TracTickets for help on using tickets.