WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#25025 closed defect (bug) (invalid)

Twenty Fourteen: widgets added to the bar extend outside widget box

Reported by: eherman24 Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.6
Component: Widgets Keywords:
Focuses: Cc:

Description

In the new TwentyFourteen theme, when you drag a new widget in to the widget box an inline style is added causing the widget to overflow outside of the widget box. I have attached an image to display the issue.

It seems that when a widget with the class names "widget ui-draggable" is clicked it adds an inline style of "margin-left:-165px; and width:405px;"

The pre-set widgets that are there when you activate the theme do not do this. I assume this is a mistake, and needs addressing.

Attachments (1)

Widgets-problem.png (17.5 KB) - added by eherman24 8 months ago.

Download all attachments as: .zip

Change History (4)

eherman248 months ago

comment:1 helen8 months ago

  • Keywords needs-patch ui-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Widgets can be given a width and height when registering and will expand outside of the area. The text widget notably does this, no matter the theme or admin style (it looks like you're using MP6).

comment:2 eherman248 months ago

  • Keywords needs-patch ui-feedback added

Sorry, didn't know this was intended.

Last edited 8 months ago by eherman24 (previous) (diff)

comment:3 SergeyBiryukov8 months ago

  • Keywords needs-patch ui-feedback removed
  • Summary changed from TwentyFourteen - widgets added to the bar extend outside widget box to Twenty Fourteen: widgets added to the bar extend outside widget box
Note: See TracTickets for help on using tickets.