WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#25044 closed feature request (duplicate)

Install translation, direct from WP-Admin

Reported by: Apiweb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

I think it would be cool, you can install translations directly from WP-Admin, I say this, because currently, it is necessary to do some procedures (though small) to install other translations, with this feature, would be much easier and faster, and to prevent the user break your installation (or can not edit the wp-config.php).

Change History (3)

comment:1 @nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Sounds like a duplicate of #18200 — or at the very least, that baseline is required for this to be able to be implemented by a plugin.

comment:2 @Apiweb20 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I saw that the ticket #18200, is now closed and implemented, however an option to install direct translation from WP-Admin left out.

comment:3 @dd3220 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

#18200 is implemented, it's just it only works for a select few plugins, and core installs the languages automatically without a UI for it (if a UI is needed, that's left to a plugin).

It'll just start working for other plugins in WordPress when the WordPress.org serverside stuff is completed for it.

I'm re-closing as a duplicate for now, once we figure out if anything extra is needed in WordPress, we'll re-open or create a new ticket with the specific implementation details needed.

Note: See TracTickets for help on using tickets.