WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 7 months ago

#25053 closed defect (bug) (fixed)

Twenty Fourteen: Add dynamic heights for each featured content

Reported by: chellycat Owned by: lancewillett
Milestone: 3.8 Priority: normal
Severity: normal Version: 3.8
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Since the entry-summary has a fixed height, in some cases, the excerpt gets cut off. (Lengthy title, many categories, smaller screen, etc.) See attached screenshot.

Users can still click the title and the thumbnail to see the post, as well as and shorten the excerpt with a custom excerpt -- so may not be worth spending too much time to fix this. However, it would be great if we can look into adding dynamic heights to the featured section.

Attachments (2)

excerpts on user blog.jpg (348.4 KB) - added by chellycat 8 months ago.
25053.diff (4.1 KB) - added by obenland 7 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 chellycat8 months ago

  • Cc michellelangston@… added

comment:2 chellycat8 months ago

  • Summary changed from Twenty Fourteen: Dynamic height for each featured content to Twenty Fourteen: Add dynamic heights for each featured content

comment:3 lancewillett8 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.8

comment:4 obenland8 months ago

  • Milestone 3.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25033.

comment:5 obenland8 months ago

  • Keywords needs-patch removed

comment:6 lancewillett8 months ago

#25033 was marked as a duplicate.

comment:7 lancewillett8 months ago

  • Keywords needs-patch added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:8 SergeyBiryukov8 months ago

  • Milestone set to 3.8

comment:9 lancewillett7 months ago

This one needs a patch still. ;)

comment:10 RDall7 months ago

  • Cc robert@… added

comment:11 iamtakashi7 months ago

  • Cc takashi@… added

comment:12 lancewillett7 months ago

This one still needs a patch.

comment:13 obenland7 months ago

  • Keywords has-patch added; needs-patch removed
  • Type changed from enhancement to defect (bug)
  • Version set to trunk

Patch prevents the title from breaking the line and lets it overflow with an ellipses.
This way both the title and the excerpts stay (more or less) constant, height-wise.

obenland7 months ago

comment:14 lancewillett7 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from reopened to closed

In 25758:

Twenty Fourteen: improve display for elements in the featured content area by preventing titles from breaking and letting content overflow with an ellipsis. Props obenland, fixes #25053.

Note: See TracTickets for help on using tickets.