WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#25109 closed enhancement (duplicate)

Detect whether rewrites are enabled

Reported by: rmccue Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

In the permalinks options page, we should use a loopback HTTP connection to check whether rewrites are enabled. A route like /wp-internal-test could return a 200 when rewrites are enabled (and a 404 when they're not obviously).

(I suspect due to bad server config, we'll have to check the body there too.)

Change History (3)

#1 @markoheijnen
6 years ago

/dashboard makes more sense I guess. Since we already control that one.

#2 @nacin
6 years ago

Duplicate of #6481, see also #12404.

#3 @chriscct7
4 years ago

  • Keywords needs-patch added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6481.

Note: See TracTickets for help on using tickets.