WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#25157 closed defect (bug) (worksforme)

get_page_by_title returns null with ampersand in title

Reported by: barrykooij Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Formatting Keywords: has-patch
Focuses: Cc:

Description

Ampersands in posts get changed to & when saved to the database. This causes get_page_by_title to return null when using a title with an ampersand.

Attachments (1)

post.php.diff (818 bytes) - added by barrykooij 7 years ago.

Download all attachments as: .zip

Change History (6)

@barrykooij
7 years ago

#1 @barrykooij
7 years ago

I accidentally uploaded 2 wrong patch files, please remove/ignore user.php.patch and user.php.patch

#3 @barrykooij
7 years ago

Seems to be working just fine now, without the patch. Ticket can be closed.

#4 @joostdevalk
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Closing, as per previous comment.

#5 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to worksforme

Could not reproduce neither in 3.6.1 nor in trunk.

Note: See TracTickets for help on using tickets.