WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#25163 closed feature request (duplicate)

Enable changing of text on wp-signup.php

Reported by: joe.woidpress Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Text Changes Keywords:
Focuses: Cc:

Description

Currently the text on wp-signup.php reads:

"Welcome back, <username>. By filling out the form below, you can add another site to your account. There is no limit to the number of sites you can have, so create to your heart’s content, but write responsibly!"

...though, in a WordPress multisite install I'm working on, we're limiting the number of sites a user can create, so "there is no limit to the number of sites you can have" is not appropriate in this case.

This multisite install is hosted by a third party and it would be best to avoid hacking the wp-signup.php core file or setting up a redirect to an alternate script. (These two methods being the only way I've found to change this text when researching the issue.)

Would it be possible to add a filter to the text on wp-signup.php line 224:

	<p><?php printf( __( 'Welcome back, %s. By filling out the form below, you can <strong>add another site to your account</strong>. There is no limit to the number of sites you can have, so create to your heart&#8217;s content, but write responsibly!' ), $current_user->display_name ) ?></p>

...or have a Network Admin option of some sort to enable changing of this default text?

...or make wp-signup.php easily themeable?

Alternately, if it would be possible to limit the number of sites individual users can create as a Network Admin option that would alter this text to reflect the set limit, that would solve the problem as well.

Change History (1)

comment:1 SergeyBiryukov8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21662.

Note: See TracTickets for help on using tickets.