WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#25166 closed defect (bug) (fixed)

New users are automatically subscribed to the main blog

Reported by: conner_bw Owned by: nacin
Milestone: 3.6.1 Priority: normal
Severity: major Version: 3.6
Component: Multisite Keywords: has-patch commit
Focuses: Cc:

Description

Prerequisites:

  • Install WordPress 3.6 Multi-Site
  • Enable "Both sites and user accounts can be registered."
  • Logout

Steps to reproduce:

  • As a new user, sign up for a new site (Aka: Gimme a site!)
  • Successfully go through the process

Expected:

  • User is not a Subscriber to main blog, rather she an Admin to her own blog.

Actual:

  • User is a Subscriber to main blog, and and Admin to her own blog.

Extra:

"Expected" was happening in 3.4, and 3.5.

This issue started happened when we upgraded to 3.6

I did a trace and add_action( 'wpmu_activate_user', 'add_new_user_to_blog', 10, 3 ); and
add_new_user_to_blog() never gets called. This is where the desired action happens.

Thank you for your consderation

Attachments (1)

25166.diff (595 bytes) - added by duck_ 20 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 @SergeyBiryukov20 months ago

  • Component changed from General to Multisite
  • Milestone changed from Awaiting Review to 3.7

Might be related to [23535] (#15173).

comment:2 @duck_20 months ago

I traced this to [23307] for #15627. AFAICT that change is invalid since delete_user_option() will add $wpdb->prefix by default, so we went from deleting wp_capabilities to wp_wp_capabilities (assuming the default prefix).

I think we should revert and re-open that ticket. It seems to me that the problem described in #15627 is about using wp_insert_user() and the capabilities removal in wpmu_create_user() was working okay.

comment:3 @nacin20 months ago

  • Milestone changed from 3.7 to 3.6.1

@duck_20 months ago

comment:4 @nacin20 months ago

  • Keywords has-patch commit added
  • Severity changed from normal to major

comment:5 @nacin20 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 25183:

Revert [23307] so new users in multisite are not automatically subscribers on the main site.

props duck_.
fixes #25166 for trunk.
see #15627.

comment:6 @nacin20 months ago

In 25184:

Revert [23307] so new users in multisite are not automatically subscribers on the main site.

Merges [25183] to the 3.6 branch.

props duck_.
fixes #25166.
see #15627.

Note: See TracTickets for help on using tickets.