WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#25167 closed feature request (duplicate)

Multiple Email Registration On Multisite

Reported by: tubiz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Multisite Keywords: dev-feedback
Focuses: Cc:

Description

Can multiple registration be allowed with a single email address across different sites in a multisite setup.
If a current user has already registered with a email address in another multisite blog, the same email address can't be used to register again.
Basically an option should be added in wp-admin to enable multiple registration with a single email address across multisite blogs.

Change History (5)

#1 @nacin
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I think this is a duplicate of #15467.

#2 @tubiz
8 years ago

So when are we seeing this implemented into WordPress or it isn't visible.
Because the ticket was opened three years ago.

#3 @nacin
8 years ago

It's not something WordPress intends to implement. Networks are cohesive pieces. Emails must be unique.

One thing you could do is, on attempted registration, let them know they already have a user account. If that's a concern (as in, they need to not know the sites are linked), then either A) the plugin idea mentioned in #15467 could be intriguing, or B) you shouldn't be using multisite.

#4 @tubiz
8 years ago

The issue is we are using multisite to implement multiple woocommerce stores each different from one another.
If a customer registered on another store with a different owner and tried to register on another store entirely with a different owner from the first store he registered he is told that he is already registered.
So we need each store to have a unique tables for user reigstration.
Is there a way this can be achieved.
Thanks a lot

#5 @TiagoVergutz
7 years ago

@tubiz, any solution for this issue? I'm with the same problem, tried to implement the solution of @lightspirit in #15467 for create separated user tables for each blog, but not worked

Note: See TracTickets for help on using tickets.