WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#25203 closed enhancement (duplicate)

Use comment_reply_link arguments to wrap reply link

Reported by: thomasguillot Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Comments Keywords: has-patch needs-refresh
Focuses: Cc:
PR Number:

Description

Avoid empty div if no reply link

wp-includes/comment-template.php

<div class="reply">
	<?php comment_reply_link( array_merge( $args, array( 'add_below' => $add_below, 'depth' => $depth, 'max_depth' => $args['max_depth'] ) ) ); ?>
</div>

to

<?php
	comment_reply_link( array_merge( $args, array(
		'add_below' => $add_below,
		'depth'     => $depth,
		'max_depth' => $args['max_depth'],
		'before'    => '<div class="reply">',
		'after'     => '</div>',
	) ) );
?>

Attachments (1)

25203.patch (781 bytes) - added by Frank Klein 6 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
6 years ago

  • Severity changed from major to normal
  • Version changed from trunk to 3.6

@Frank Klein
6 years ago

#2 @Frank Klein
6 years ago

  • Cc contact@… added

#3 @Frank Klein
6 years ago

  • Keywords has-patch added; needs-patch removed

#4 @rachelbaker
5 years ago

  • Keywords needs-refresh added
  • Milestone changed from Awaiting Review to Future Release

+1 here. I would like to see the patch refreshed and the HTML comment removed from the 'after' argument.

#5 @Oxymoron
5 years ago

Just looked into this- and no need for a patch anymore. It seems as though this got solved somewhere along the line.

#6 @rachelbaker
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

My fault! Looks like this was fixed in 29908

#7 @helen
5 years ago

  • Milestone Future Release deleted
  • Resolution changed from fixed to duplicate

Duplicate of #29895.

Note: See TracTickets for help on using tickets.