WordPress.org

Make WordPress Core

#25204 closed defect (bug) (fixed)

youtube embed video wrong dimensions

Reported by: Alexufo Owned by:
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.2
Component: Embeds Keywords:
Focuses: Cc:

Description

  1. try to embed http://www.youtube.com/watch?v=5EayDPIjp40 at default wordpress theme.
  1. You will see 4:3 but not originally 16:9. I didnt know why videos embeds differently. This video has error of embed height.

Change History (3)

comment:1 @SergeyBiryukov19 months ago

Confirmed. These are the parameters sent to YouTube using Twenty Fourteen:

array( 'width' => 474, 'height' => 711, 'discover' => false )

This what we get back from YouTube:

<iframe width="474" height="356" src="http://www.youtube.com/embed/5EayDPIjp40?feature=oembed" frameborder="0" allowfullscreen></iframe>

The correct height for a 16:9 video would be 266px here, but this looks like a YouTube issue.

comment:2 @SergeyBiryukov19 months ago

  • Component changed from General to Embeds

comment:3 @wonderboymusic11 months ago

  • Milestone changed from Awaiting Review to 4.0
  • Resolution set to fixed
  • Status changed from new to closed

This loads in 2014 theme as 474 x 232 now, so problem solved. I admittedly don't know when this was fixed...

Note: See TracTickets for help on using tickets.