WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#25205 closed enhancement (duplicate)

filter for submenu_as_parent parameter

Reported by: plocha Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.6
Component: Administration Keywords: has-patch
Focuses: Cc:
PR Number:

Description

This filter enables plugins to remove the menu entries which have the same target as their parents.

We could use this filter to determine whether /wp-admin/menu.php and add_submenu_page should add 'same target' submenu entries. But I think there is no need for it because some plugins manually add such submenu entries. So plugins which use this filter should remove them manually.

Attachments (1)

submenu-as-parent.patch (345 bytes) - added by plocha 6 years ago.

Download all attachments as: .zip

Change History (4)

#1 @plocha
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19085.

#2 @SergeyBiryukov
6 years ago

  • Version changed from trunk to 3.6

#3 @markoheijnen
6 years ago

  • Milestone Awaiting Review deleted

Clearing out the milestones for closed tickets on Awaiting Review

Note: See TracTickets for help on using tickets.