WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#25206 closed defect (bug) (fixed)

default_password_nag logic behavior

Reported by: wikicms Owned by: SergeyBiryukov
Milestone: 3.7 Priority: normal
Severity: minor Version: 3.6
Component: Users Keywords: has-patch commit
Focuses: Cc:

Description

Step to reproduce:

  1. Register on blog

If we login at that moment we'll see notification about needed to change default password. It's okay.

  1. Reset Password and click confirm link, write new password.
  2. Login now

Default Notification about change password we'll see again. Oops. Why? If we have own password, changed manually.

Investigation in code:
Adds default_password_nag when new user registered http://core.trac.wordpress.org/browser/tags/3.6/wp-login.php#L361

And not deleted or changed when password is resetting http://core.trac.wordpress.org/browser/tags/3.6/wp-login.php#L306

Attachments (1)

25206.patch (746 bytes) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (3)

SergeyBiryukov8 months ago

comment:1 SergeyBiryukov8 months ago

  • Keywords has-patch commit added; needs-patch dev-feedback removed
  • Milestone changed from Awaiting Review to 3.7

comment:2 SergeyBiryukov8 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 25203:

Clear 'default_password_nag' flag when resetting a user's password, since the new password is entered manually. props wikicms. fixes #25206.

Note: See TracTickets for help on using tickets.