WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#25413 closed defect (bug) (invalid)

Twenty Fourteen: Footer widgets break in IE9 when using sidebar-3 ( Content Sidebar)

Reported by: wycks Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:
PR Number:

Description

Steps to reproduce:

  1. Enable some default widgets for all sidebars under "Widgets".
  2. Check browser in ie9, the widgets are all stacked to the left

Removing widgets from "Content Sidebar" remedies the problem, what seems to happen is that when sidebar-3 (Content Sidebar) is active it applies an inline position:absolute via jquery-masonry.

Patch sets footer widget container style to null as per masonry docs.

Attachments (2)

25413.diff (402 bytes) - added by wycks 6 years ago.
09-25-2013[1].jpg (34.2 KB) - added by wycks 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (6)

@wycks
6 years ago

@wycks
6 years ago

Screenshot

#1 @iaintaylor
6 years ago

Hi WYCKS,
Thanks for your ticket. Unfortunately I was unable to reproduce this issue in IE9 or IE10 but were able to see some issues in IE8.

Can you take a look at it again and see if there might be other aspects that might be unique to your own install.

Thanks
Iain

#2 @wycks
6 years ago

I just tested a clean WordPress 3.7-beta1-25639, Twenty Fourteen 0.1 .

Browser Mode: IE9
Document Mode: IE9 Standard (default)
Version: 9.0.8112.16421 (final release)

I still see the same problem http://i.imgur.com/j4nBNwD.jpg (IE overlyed on top of chrome showing - footer area)

I can test this on some other OS's tonight to see if that makes any diff or if it is something local.

Last edited 6 years ago by wycks (previous) (diff)

#3 @wycks
6 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

Further tested remotely and it looks fine on Windows 7, 8 , for some odd reason the sidebar remains vertical on Vista using IE9 and only when the Content Sidebar is used along with the Footer sidebar (though the patch does fix it oddly enough).

Closing since I it's probably localised issue, maybe the ghost of IE past.

#4 @SergeyBiryukov
6 years ago

  • Keywords 2nd-opinion close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.