WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#25480 closed defect (bug) (duplicate)

Date input fields in quick edit panel need labels

Reported by: grahamarmfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6.1
Component: Accessibility Keywords:
Focuses: Cc:
PR Number:

Description

This is similar to #25461 but concerns a different location.

When the quick edit panel is opened for a post or page the published date fields do not have associated labels. This means that screen reader users may not realise what the input fields are for. Also, voice recognition users cannot directly access the input fields.

The labels should ideally be visible to help everyone understand what input is required.

Change History (4)

#1 @sharonaustin
6 years ago

Ok, trying again. Based on buffler's solution for ticket #25461, and understanding the relevant source code to be in /wp-admin/includes/ -> class-wp-posts-list-table.php based on the following article from Shiba: http://shibashake.com/wordpress-theme/expand-the-wordpress-quick-edit-menu I'll adapt buffler's solution to lines:

586-590
771-776
844-864
1069-1077

I'll be back with actual work, sorry for being so PAINFULLY slow on all this.

#2 follow-up: @buffler
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

@sharonaustin, this actually involves the same function as #25461 does (touch_time), so applying the patch presented there fixes this issue also.

Sorry, I mentioned this in the other ticket, but forgot to mention it here as well. I'll close this now as a duplicate of #25461.

#3 in reply to: ↑ 2 @sharonaustin
6 years ago

Replying to buffler:

@sharonaustin, this actually involves the same function as #25461 does (touch_time), so applying the patch presented there fixes this issue also.

Sorry, I mentioned this in the other ticket, but forgot to mention it here as well. I'll close this now as a duplicate of #25461.

No problem! Thanks for taking care of it! I just love to see accessibility tickets knocked out! Keep rocking it!

Last edited 6 years ago by sharonaustin (previous) (diff)

#4 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.