WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#25482 closed feature request (duplicate)

Automatically Make Child Pages Sub Menu Items in Menu Editor

Reported by: toddswardenski Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Menus Keywords:
Focuses: Cc:

Description

One of the most time consuming tasks for me when I'm setting up a new WordPress site for a client is the menu creation. I create all the pages, set the parent pages for each page during the initial setup, then create the menus in the menu editor once my sitemap has been created with the correct relationships.

When I'm creating a menu in the menu editor, I select multiple pages at a time and generally when I have a child page I want that same page to appear in the sub menu of the parent page in the navigation.

When selecting both parent and children pages in the menu editor, can those children pages automatically be put into the menu as sub menu items of the parent page? It would save a lot of time for me personally, and I'm sure I'm not the first person to come across the issue.

I did a quick search for this topic, but found nothing previously submitted. Apologies if it is, in fact, a duplicate request.

http://puu.sh/4GJAk

Change History (1)

#1 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25483.

Note: See TracTickets for help on using tickets.