WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#25505 closed defect (bug) (duplicate)

Hook Docs: wp-includes/post.php

Reported by: dougwollison Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Inline Docs Keywords:
Focuses: Cc:

Description

Added patch has inline docs for the following hooks found in wp-includes/post.php:

  • get_attached_file
  • update_attached_file
  • _wp_relative_upload_path
  • registered_post_type
  • post_type_labels_{$post_type}
  • edit_{$field}
  • {$field_no_prefix}_edit_pre
  • edit_post_{$field}
  • pre_{$field}
  • {$field_no_prefix}_save_pre
  • pre_post_{$field}
  • {$field}_pre
  • {$field}
  • post_{$field}
  • post_mime_types
  • before_delete_post
  • delete_post
  • deleted_post
  • after_delete_post
  • wp_trash_post
  • trashed_post
  • untrash_post
  • untrashed_post
  • trash_post_comments
  • trashed_post_comments
  • untrash_post_comments
  • untrashed_post_comments
  • wp_insert_post_empty_content
  • wp_insert_post_parent
  • wp_insert_post_data
  • pre_post_update
  • edit_post
  • post_updated
  • save_post_{$post->post_type}
  • save_post
  • wp_insert_post
  • wp_unique_post_slug_is_bad_attachment_slug
  • wp_unique_post_slug_is_bad_hierarchical_slug
  • wp_unique_post_slug
  • add_ping
  • get_enclosed
  • get_pung
  • get_to_ping
  • get_pages
  • edit_attachment
  • add_attachment
  • delete_attachment
  • wp_delete_file
  • wp_get_attachment_metadata
  • wp_update_attachment_metadata
  • wp_get_attachment_url
  • wp_get_attachment_thumb_file
  • wp_get_attachment_thumb_url
  • icon_dir
  • icon_dir_uri
  • `icon_dirs †
  • wp_mime_type_icon
  • pub_priv_sql_capability
  • get_lastpostdate
  • get_lastpostmodified
  • clean_post_cache
  • clean_page_cache
  • clean_attachment_cache
  • private_to_published
  • xmlrpc_publish_post

† These may need additional work.

Attachments (1)

25505-patch.diff (30.6 KB) - added by dougwollison 6 years ago.
Fixed diff file with missing punctuation.

Download all attachments as: .zip

Change History (4)

#1 @dougwollison
6 years ago

Missed a few punctuation details, uploading revised diff shortly.

@dougwollison
6 years ago

Fixed diff file with missing punctuation.

#2 @kpdesign
6 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25376.

Note: See TracTickets for help on using tickets.