WordPress.org

Make WordPress Core

#25595 closed feature request (duplicate)

Option to turn off comments on pages/posts

Reported by: ThemePrince Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords:
Focuses: Cc:

Description

Hello! :)

I know that it mostly depends on themes, however I think there should be an option in Settings - Discussion to disable comments on posts/pages or everywhere.

Just check this plugin's download stats to see that many people need it: http://wordpress.org/plugins/disable-comments/stats/

Change History (3)

comment:1 @kpdesign23 months ago

  • Keywords needs-ui removed

Related: #17478.

You can already turn off comments on pages/posts under Settings > Discussion > Default Article Settings by unchecking the box next to "Allow people to post comments on new articles (These settings may be overridden for individual articles.)". However, this setting only changes the defaults for new posts/pages created after the settings change. It does not turn off comments for existing posts/pages.

Last edited 23 months ago by SergeyBiryukov (previous) (diff)

comment:2 @ThemePrince23 months ago

kpdesign: that's the problem, exactly! :)

comment:3 @SergeyBiryukov23 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17478.

Note: See TracTickets for help on using tickets.