WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#25622 closed defect (bug) (fixed)

Plugin change log link incorrect on multisite updates screen

Reported by: mindctrl Owned by: nacin
Milestone: 3.7 Priority: normal
Severity: normal Version: 3.7
Component: Multisite Keywords:
Focuses: Cc:

Description

In 3.7-beta2-25801 multisite, there's a problem with the link that shows the change log when there's an update available for plugins. I've tested on two clean multisite installs. When visiting the wp-admin/network/update-core.php screen, the "View version x.x details" link is missing the "network" piece of the URL. When the iframe pops, you get the "Install Plugins" screen instead of the plugin change log.

The link is not broken on the main Plugins screen. It correctly displays the change log.

Visit
http://37beta2/wp-admin/network/update-core.php

The link looks like this (note it's missing "network" after "wp-admin")
http://37beta2/wp-admin/plugin-install.php?tab=plugin-information&plugin=plugin-name&section=changelog&TB_iframe=true&width=640&height=670

Visit
http://37beta2/wp-admin/network/plugins.php

The link looks like this (link is correct)
http://37beta2/wp-admin/network/plugin-install.php?tab=plugin-information&plugin=plugin-name&section=changelog&TB_iframe=true&width=600&height=800

Change History (7)

#1 @mindctrl
6 years ago

  • Cc public@… added

#2 @jeremyfelt
6 years ago

  • Milestone changed from Awaiting Review to 3.7
  • Severity changed from major to normal

Confirmed. The is_admin and is_network properties of the $current_site global are reset by a new set_current_screen( 'tools' ); call when requesting file system credentials in the Automatic Upgrader Skin

Introduced in [25228]

Last edited 6 years ago by jeremyfelt (previous) (diff)

#3 follow-up: @nacin
6 years ago

I don't think the set_current_screen() call is required anymore, thanks to [25806].

#4 in reply to: ↑ 3 @dd32
6 years ago

Replying to nacin:

I don't think the set_current_screen() call is required anymore, thanks to [25806].

Off the top of my head, that would be correct. Removing it shouldn't cause any problems.

#5 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 25836:

set_current_screen() is now unnecessary in Automatic_Upgrader_Skin, which is good because it breaks things in the network admin.

fixes #25622.

#6 @SergeyBiryukov
6 years ago

  • Version changed from trunk to 3.7

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.