WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2565 closed defect (bug) (fixed)

Posts won't save/submit if longer than a certain number of characters

Reported by: JPigford Owned by:
Milestone: Priority: highest omg bbq
Severity: critical Version: 2.0.1
Component: Administration Keywords:
Focuses: Cc:

Description

When I (or any user of the blog) try to make a post we frequently get a 404 error page when we save or publish (it takes you to /wp-admin/post.php).

We've found that it only does this after we reach a certain number of characters in the post. If we shorten the post it will publish/save.

Change History (3)

comment:1 @majelbstoat9 years ago

  • Milestone changed from 2.0.2 to 2.1

Firstly,

Have you tried it with all plugins removed?
Have you tried it after removing all update services from the notification list?

Then, this will be tedious, but could you count the number of characters at which point it breaks? If you chop by paragraph, sentence then word it shouldn't take too long hopefully... You can count the characters in most text editors.

Also, you set this as milestone 2.0.1. Have you tried it with 2.0.2 (which is already out the door)?

Cheers.

comment:2 @JPigford9 years ago

  • Milestone changed from 2.1 to 2.0.2
  • Resolution set to fixed
  • Status changed from new to closed

Okay, I removed all plugins and update services and it still did it.

Concerning the milestone, I could have sworn I marked 2.0.2...but looks like it didn't take. I'm using 2.0.2.

Now, I think I actually may have found the problem. It seems that mod_security was catching certain keywords in posts and flagging them...ultimately not letting the post through. So...at this point it seems this ticket could be closed.

comment:3 @anonymous9 years ago

  • Milestone 2.0.2 deleted

Milestone 2.0.2 deleted

Note: See TracTickets for help on using tickets.