Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#25653 closed defect (bug) (fixed)

Fix the filter names for core auto update emails

Reported by: nacin's profile nacin Owned by: nacin's profile nacin
Milestone: 3.7 Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:


Somehow I ended up with automatic_updates_send_email as a pre-filter (to disable the email) and automatic_update_send_email as a filter on the email headers and body.

What they should be is auto_core_update_send_email and auto_core_update_email.

Some filters do use automatic_updates or automatic_updaters for the overarching background updater. But in this case auto_core_update should be used; the similar root words are used elsewhere for other filters like auto_update_$type and allow_(minor|dev|major)_auto_core_updates.

Change History (1)

#1 @nacin
11 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 25859:

Rename the automatic_updates_send_email filter to auto_core_update_send_email. (Final name change.)

fixes #25653. Also:

  • Fully document all new hooks, methods, and classes in the upgrader.
  • Rename 'language' to 'translation' inside the upgrader.
  • Improve the readability of the crazy do-while loop in the is_vcs_checkout() method.
Note: See TracTickets for help on using tickets.