WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#25697 closed defect (bug) (invalid)

User search in network admin returns different results to user search in a sub-site

Reported by: tomdxw Owned by: johnbillion
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Users Keywords:
Focuses: administration, multisite Cc:

Description (last modified by DrewAPicture)

I just created a new user called "abc123" with an email address of "camel@example.com" on the main site of a multisite installation.

I performed the following searches in both /wp-admin/users.php and /wp-admin/network/users.php:

  • "camel@example.com" finds the user in both cases
  • "@example.com" finds the user only on the non-network search
  • "camel@" finds the user only on the non-network search
  • "example.com" does not find the user
  • "camel" does not find the user

It would be helpful to be able to search for @example.com in the network admin for instance when we receive bounce emails which don't specify the full email address.

Change History (8)

#1 @tomdxw
7 years ago

  • Cc tom@… added

#2 @DrewAPicture
7 years ago

  • Description modified (diff)

#3 @jeremyfelt
7 years ago

  • Version changed from 3.7 to 3.1

This behavior was set in place by [17189] via #16014, in which a specific decision was made to wrap single site searches with a leading and trailing * for wildcard searching while leaving it to the searcher to add a wildcard in multisite.

Searching with an explicit wildcard as *@example.com and camel@* should work as intended unless wp_is_large_network( 'users' ) is true. If so, then leading wildcards will be stripped and only camel@* should work as intended.

For the example.com and camel searches, if the @ character is not found in a search term, WP_User_Query does not include user_email in the search and looks in user_login and user_nicename instead. This behavior can be filtered with user_search_columns, introduced in [24056].

IMO, the way wildcards are treated between single and multisite makes sense. See #20661 for a request to better document this in the admin help.

The search behavior around @ is somewhat confusing and could be interesting to take another look at.

Related: #15170, #16366, #20135

#4 @jeremyfelt
7 years ago

  • Component changed from Network Admin to Users
  • Focuses administration added

This ticket was mentioned in Slack in #core-multisite by sergey. View the logs.


5 years ago

#7 @johnbillion
5 years ago

  • Owner set to johnbillion
  • Status changed from new to reviewing

#8 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reviewing to closed

Each of the issues raised in this ticket are invalid since #32913.

Note: See TracTickets for help on using tickets.