WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#25737 closed defect (bug) (duplicate)

Duplicated category URLs

Reported by: riccardo.raneri Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Canonical Keywords:
Focuses: Cc:

Description

When using nested categories, every URL that ends with a valid category slug works. For example (using WooCommerce, but you get the same with the standard WP structure, "category" instead of "products"):

In this example, "pasta" is a subcategory of "pasta-and-risotto". If you go to the three URLs above you'll get the same page.

This is wrong from a logic point of view, because only the first URL is correct (it respects the structure of categories I have set in the admin interface -- in fact, the automatic navigation menu links to this one). In addiction of this, it generates duplicated content.

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18734.

Note: See TracTickets for help on using tickets.