WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#25790 closed defect (bug) (duplicate)

Page properties reseted on Update Page in Quick Edit

Reported by: wpfo Owned by:
Milestone: Priority: normal
Severity: major Version: 3.6
Component: Quick/Bulk Edit Keywords: reporter-feedback
Focuses: Cc:

Description

Serious error by click on Update Page in Quick Edit (in-line edit tool).
(Error in WP Versions 3.6.1, 3.7 and in current trunk 3.8-alpha)

1)
To uncheck the option "Allow Comments" an user must use "quick edit" link under the Page Title in the Table of Pages.
(Maybe also wrong. This option should be accessible in main page edit screen, as earlier, or at least
Allow Comments should be unchecked by default).

2)
By click on Update Button in Quick Edit to save the Edits made to this Page, Page will be shown in the list of pages as:
"(no title)"

3)
By click on Edit link of "(no title)" page we see that the following Page properties are reseted:

  • Page Title (The title of the page)
  • Permalink
  • Template (Page Template to use for presenting this Page.)
  • Order (Page order to sort the list of Pages.)

Attachments (4)

_err_quick_editt__edit_page__screenshot.jpg (149.0 KB) - added by wpfo 7 years ago.
Screenshot: Edit Page
_err_quick_editt__page_table_no_title_page__screenshot.jpg (106.3 KB) - added by wpfo 7 years ago.
Screenshot: "(no title)" page
_err_quick_editt__in-line edit__screenshot.jpg (149.4 KB) - added by wpfo 7 years ago.
Screenshot: Quick Edit
_err_quick_editt__edit_page_properties reseted__screenshot.jpg (138.8 KB) - added by wpfo 7 years ago.
Screenshot: Edit Page, properties reseted

Download all attachments as: .zip

Change History (6)

@wpfo
7 years ago

Screenshot: Edit Page

@wpfo
7 years ago

Screenshot: "(no title)" page

@wpfo
7 years ago

Screenshot: Quick Edit

@wpfo
7 years ago

Screenshot: Edit Page, properties reseted

#1 @helen
7 years ago

  • Keywords reporter-feedback added

IE8? If so, this is a duplicate of #24923.

#2 @SergeyBiryukov
7 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from critical to major
  • Status changed from new to closed
  • Version changed from trunk to 3.6

Duplicate of #24923.

The screenshots do look like IE8.

Note: See TracTickets for help on using tickets.