WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 8 years ago

#2582 closed defect (bug) (fixed)

Full text feed problem when using <!--more--> tag

Reported by: tinyau Owned by: davidhouse
Milestone: 2.5 Priority: normal
Severity: major Version: 2.1
Component: General Keywords: ryan
Focuses: Cc:

Description

In the current revision 3645, the text after <!--more--> tag will not be shown in feed even 'Full text' feed option is selected in admin panel.

Attachments (1)

2582-remove-option-warning.diff (833 bytes) - added by lloydbudd 8 years ago.
Need to remove paragraph warning on Reading Settings

Download all attachments as: .zip

Change History (33)

#1 @davidhouse
10 years ago

  • Owner changed from anonymous to davidhouse
  • Status changed from new to assigned

#2 @davidhouse
10 years ago

<MarkJaquith> I think that's intended, but I'm not sure
<MarkJaquith> <!--more--> might imply that you want them to go to the permalink to read the thing
<MarkJaquith> the feed just shows what would show on the front page of your site
<MarkJaquith> That seems like good behavior to me
<davidhouse> true
<davidhouse> we don't show stuff after more even with Full Text

#3 @markjaquith
10 years ago

This is intended behavior. By putting <!--more--> you're saying that you want people to view the permalink to see the whole article. In this case, what is shown on your feed and on the front page is the same.

#4 @davidhouse
10 years ago

  • Resolution set to invalid
  • Status changed from assigned to closed

Eurgh. Trac.

<MarkJaquith> I think that's intended, but I'm not sure
<MarkJaquith> <!--more--> might imply that you want them to go to the permalink to read the thing
<MarkJaquith> the feed just shows what would show on the front page of your site
<MarkJaquith> That seems like good behavior to me
<davidhouse> true
<davidhouse> we don't show stuff after more even with Full Text

#5 @masquerade
10 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

If this is the case, we should remove anything after <!--more--> for the description also.

#6 @masquerade
10 years ago

Also (sorry for the mail spam wp-trac subscribers), an empty link like
<a href="http://localhost/trunk/?p=55#more-55"></a>
shouldn't be left in the encoded field either, and perhaps the option name should be changed to disambiguate so that someone else doesn't report this as a bug.

#7 @tinyau
10 years ago

Then the intended behavior is different from WordPress 1.5.2? In WordPress 1.5.2, the text after <!--more--> tag is still shown in full text feed.

#8 @tinyau
10 years ago

No comment on different behavior between WordPress 1.5.2 and 2.1-alpha?

#9 @markjaquith
10 years ago

Cutting off at <!--more--> makes sense to me, but maybe it should be an option, like (excerpt, everthing before <!--more-->, everything)

If the behavior truly has changed, then it needs clarification

#10 @tinyau
10 years ago

No comments from the developers about the different behavior between WordPress 1.5 and WordPress 2 for such a long time?

#11 @ryan
10 years ago

I see lots of comments from developers.

We just need to make a policy decision. 1.5 or 2.0 style. At this point, if we change it back to 1.5 style, we'll get bugs saying "2.1 is different than 2.0". So, somebody pick. Flip a coin.

#12 @markjaquith
10 years ago

Argument in favor of 2.0 style:

<!--more--> hides stuff from your front page, so that people have to view the entry itself to get the whole thing. Your feed is basically a machine-readable version of your front page... why should it be any different? If you wanted people to read the whole thing without an additional click, why use <!--more--> at all?

Another reason:
changing it again will create even more confusion than has been caused by the change in 2.0 ... they'll write limericks about us:

There once was a CMS from Automattic,
That had <!--more--> behavior quite erratic.
They flipped and they flopped, until Podz's poor head popped
And the forums were put to a panic.

#13 @matt
10 years ago

Yes, but we do really need a (read more...) link in the full-text feeds, because it can be quite confusing when an entry truncates and there is no visual indication that there's more out there.

#14 @tinyau
10 years ago

I don't think the feed is exactly the machine-readable version of front page. Feed is the syndication of the article and I think it should be no relationship between feed and '<!--more-->' tag. I think '<!--more-->' tag is just a way to control the presentation of the articles in the front page. 'Full text' feed should mean to display the whole content of the article and if not, why it was called 'Full text' feed?

@ryan, even 2.1 behavior is reverted back to the way as 1.5. If it is stated clearly in the release notes, it should be no problem.

#15 @tinyau
10 years ago

In addition, I have to emphasis that the behavior in WordPress 1.5.x and 2.0.x is the same. It is changed in WordPress 2.1 Alpha.

#16 @tinyau
10 years ago

Any progress? Since the behavior of WordPress 1.5.x and 2.0.x is the same, keep it the same in version 2.1 should be the most appropriate approach.

#17 @ryan
10 years ago

[4184] adds the more link.

#18 @tinyau
10 years ago

Changeset 4184 show the more hyperlink in feed if use <!--more--> tag in the posts. Is it the policy confirmed by all developers? If so it is different from the behavior in 1.5 and 2.0 and needs clarification to the public. I would like to see an option to revert back to the behavior of 1.5 and 2.0.

#19 @matt
10 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

This is the intended behaviour.

#20 @afaik
10 years ago

I have a tendency to write long blog posts, in WordPress 2.0.X I used the <!--more--> tag to shorten my front page but my feed was set to full-text and the full post was displayed. After upgrading to 2.1, I don't get the full post. To sum it up, I agree with tinyau. I've found a way to fix this in the support forums (http://wordpress.org/support/topic/88696) but I'm surprised by the new default behavior.

#21 follow-up: @rmm5t
9 years ago

There is a lot of discussion around this topic. It's evident that some people feel one way, while other's feel another. Personally, while I understand the reasoning behind the change, breaking backwards compatibility in a minor release (2.0 -> 2.1) is the underlying problem IMO.

I think this deserves to be be made into a config option, especially when plugins start to pop up to change the behavior of a new feature to work like an old feature.

#22 in reply to: ↑ 21 @foolswisdom
9 years ago

Replying to rmm5t:

breaking backwards compatibility in a minor release (2.0 -> 2.1) is the underlying problem IMO.

While I don't like this change in behavior, appealing to the size of the version # increment has never been a compelling argument to me. 2.1 from 2.0 represents a years+ worth a work, and has always been presented as a major release. Use of version number in the industry has never been consistent. If you have some best practice references, I would enjoy seeing them.

#23 @ryan
9 years ago

Many people want to be able to hide things below the fold, such as spoilers and NSFW pictures, in their full text feeds.

#24 @derjohng
9 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I have 'Full text' feed in version 2.0.X about one year.
Why is it removed in version 2.1?
I need <!--more--> for page view.
And I need 'full text' feed for RSS reader.

#25 @foolswisdom
9 years ago

  • Milestone 2.1 deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

#26 @ComputerGuru
9 years ago

CompleteRSS[1] plugin released during the 2.1 alpha addresses this issue, though I'd love to see it "fixed" in 2.2.

[1]: http://neosmart.net/dl.php?id=2

#27 @markjaquith
9 years ago

A lot of people don't like this new behavior. This might be one case where a third option for RSS output is warranted.

#28 @zamoose
9 years ago

A lot of people don't like this new behavior. This might be one case where a third option for RSS output is warranted.

I'll drink to that.

#29 @ryan
8 years ago

  • Milestone set to 2.5
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Looking back, this was a mistake. By popular demand, we're returning to disregarding the more tag when serving feeds.

#30 @ryan
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6763]) Show full content, including content after the more tag, for feeds. fixes #2582

@lloydbudd
8 years ago

Need to remove paragraph warning on Reading Settings

#31 @lloydbudd
8 years ago

  • Keywords ryan added
  • Resolution fixed deleted
  • Status changed from closed to reopened

#32 @ryan
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6771]) Remove warning about more tag cutting off posts in feeds. Props lloydbudd. fixes #2582

Note: See TracTickets for help on using tickets.