WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 3 years ago

#25828 closed enhancement (fixed)

Plugin update: provide progress and end indications

Reported by: Satri Owned by: obenland
Milestone: 4.6 Priority: normal
Severity: normal Version: 3.7.1
Component: Upgrade/Install Keywords: ux-feedback shiny-updates
Focuses: administration Cc:
PR Number:

Description

Minor enhancement suggestion. Applies to WP 3.7.1.

The problem:

When we start updating plugins from /wp-admin/update.php?action=upgrade-plugin page, there's no way for the user to know if the process has ended or not. If the last step printed is the last one or not.

There's also the danger that users may wrongly think the process is completed while it is not and close the browser tab before the update process is actually complete.

Details:

Currently, when we update plugins, we get an output such as this one:

The problem is that we don't know, when the line appears, if, "plugin updated successfully" is the last step or not. It isn't! Then when we see "Plugin reactivated successfully", is that the last step? It is, but the user can't tell.

The solution

Simply provide some kind of progress report. It could be as simple are marking lines with 1/6, 2/6... 6/6.

Thus the output provided to users could be like:

  • 1/6 - Downloading update from https://downloads.wordpress.org/plugin/the-plugin.zip
  • 2/6 - Unpacking the update…
  • 3/6 - Installing the latest version…
  • 4/6 - Removing the old version of the plugin…
  • 5/6 - Plugin updated successfully.
  • 6/6 - Plugin reactivated successfully.

This way, there's no confusion. Less chances of users closing windows before the completion of the update. You get happier users!

What do you think? Cheers -- Alex

Change History (7)

#1 @dd32
6 years ago

There's currently two different behaviours:

  1. Update from Plugins page, and end up with something like this: https://i.cloudup.com/Wq0ODNtLyO-3000x3000.png
  2. Update from Dashboard -> Updates, ad end up with something like this: https://i.cloudup.com/X6uwpXkMyp-3000x3000.png

#2 @jdgrimes
6 years ago

I have also noticed this. For the most part it is clear that the update isn't complete because of the ellipsis after each step. The main problem I see is that there is no ellipsis after it says "Plugin updated successfully". I'm assuming this is because the process would be finished at that point for plugins that aren't active. But active plugins need to be reactivated, so that adds an extra step. I think it would be better to display the updated successfully message with the ellipsis if the plugin needs to be reactivated. I don't know how well all of this is reflected in translations, though. @Satri's solution may be better from an l10n standpoint.

#3 @dd32
6 years ago

  • Milestone changed from Awaiting Review to Future Release

We primarily don't use numbered steps because we don't always know how many steps we're going to output ahead of time, we also actually do a bunch more steps that the user is never really told about too.

All of the Update UI's need a UI refresh though, It's something I've talked to a few people about, just none of us have had the time or personal mockups trac-able.

#4 @gingerling
5 years ago

I came here to report this exact thing - I hadn't been updating plugins for a while for a variety of reasons and when I did it for the first time in ages I thought the process had stalled, especially as there is a lot of blank space between the steps and the link to go back, as if there are more steps to come:

One possible, simple fix could be to make back link appear more snugly at the bottom of the list
If possible make the back link only appear once the process as finished

see mockup here

http://community.phplist.com/wp-content/uploads/2014/10/Screenshot-from-2014-10-03-111206.png

Another fix could be to edit the last step to say "You're done" or "Update Finished" or something similar, like so:

http://community.phplist.com/wp-content/uploads/2014/10/Screenshot-from-2014-10-03-111206_2.png

#5 @chriscct7
4 years ago

  • Focuses administration added
  • Keywords needs-patch ux-feedback added

What about having a loading gif or something like that which makes it clear that the upgrade is still running?

#6 @obenland
3 years ago

  • Keywords shiny-updates added; needs-patch removed
  • Milestone changed from Future Release to 4.6
  • Owner set to obenland
  • Status changed from new to assigned

#7 @obenland
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 37714:

Update/Install: Shiny Updates v2.

Gone are the days of isolation and feelings of "meh", brought on by The Bleak Screen of Sadness. For a shiny knight has arrived to usher our plugins and themes along their arduous journey of installation, updates, and the inevitable fate of ultimate deletion.

Props swissspidy, adamsilverstein, mapk, afragen, ocean90, ryelle, j-falk, michael-arestad, melchoyce, DrewAPicture, AdamSoucie, ethitter, pento, dd32, kraftbj, Ipstenu, jorbin, afercia, stephdau, paulwilde, jipmoors, khag7, svovaf, jipmoors, obenland.
Fixes #22029, #25828, #31002, #31529, #31530, #31773, #33637, #35032.

Note: See TracTickets for help on using tickets.