WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#25900 closed enhancement (duplicate)

Allow exclude_tree to accept a comma-separated list of parent page IDs

Reported by: awoz Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Query Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Reference: http://codex.wordpress.org/Function_Reference/wp_list_pages

As documented by wp_list_pages(), consider extending/fixing 'exclude_tree' so that it accepts a comma-separated list of parent Page IDs. One possible solution for get_pages() was previously posted here: #16202

I've attempted to use a plugin that calls wp_list_pages with a comma-separated list of parent ID. Unfortunately, the core API for this function ignores more than one parent ID.

Thanks.

Change History (2)

comment:1 SergeyBiryukov5 months ago

  • Description modified (diff)
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9153, #16202, and #19478.

comment:2 awoz5 months ago

Sergey,

Thanks for your evaluation. I now see that a resolution is planned for 3.8 per #9153.

-cheers

Note: See TracTickets for help on using tickets.