WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 3 months ago

#25933 closed defect (bug) (wontfix)

Paragraph Width In Editor Styles Introduces Resize Handles In All Versions of IE

Reported by: kyleunzicker Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.7.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

To reproduce:

  1. Load an editor stylesheet via add_editor_style()
  2. Declare a width (or max-width) on paragraphs such as:
    p { width: 80%; }
    
  3. In any version of IE (I have tested in 10, 9, and 8), edit an existing post and notice resize handles around paragraphs like so: http://kunzi.me/Hfpa

The resizable content then becomes difficult/impossible to edit.

This happens on a clean install of 3.7.1 in any theme with no plugins activated.

Change History (3)

comment:1 @ocean9013 months ago

  • Keywords needs-patch added

Hello kyleunzicker, thanks for the report.

The issue still exists in TinyMCE 4.0. p { width: 80%; } seems really rare since the width of the editor is another one as on the frontend, so you would end up in mixed widths.

comment:2 @azaozz13 months ago

This is a "feature" in all IE. Any block element that "hasLayout" inside contenteditable gets wrapped in thick border and/or gets resize handles when focused.

The only fix in this case would be to set p { width: auto !important; }.

comment:3 @iseulde3 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This is a problem in IE and not something we can fix, unless we revert it with p { width: auto !important; }. The theme shouldn't add a width to the paragraphs.

Note: See TracTickets for help on using tickets.