WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#25940 closed defect (bug) (duplicate)

CSS Selector Causing Issues

Reported by: dovyp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Inside /wp-admin/css/wp-admin-rtl.min.cs is the following class:

.screen-reader-text,.screen-reader-text span,.ui-helper-hidden-accessible{

position:absolute;
left:-1000em;
top:-1000em;
height:1px;
width:1px;
overflow:hidden

}

Having the .ui-helper-hidden-accessible specified without a .screen-reader-text causes problems for others trying to use the button_set from Wordpress UI.

Easy fix is to change the above to:
.screen-reader-text,.screen-reader-text span,.screen-reader-text .ui-helper-hidden-accessible{

position:absolute;
left:-1000em;
top:-1000em;
height:1px;
width:1px;
overflow:hidden

}

Or something along those lines. It needs a prefix or an alternate class to not conflict.

The effect is with button_bar/button_set scrolling to the top of the page after each click.

Change History (2)

comment:1 follow-up: helen5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I have no idea what button_bar is, but I'm going to assume this is a duplicate of #23684.

comment:2 in reply to: ↑ 1 dovyp5 months ago

Replying to helen:

I have no idea what button_bar is, but I'm going to assume this is a duplicate of #23684.

You are correct. I should have searched first. Thank you.

Note: See TracTickets for help on using tickets.