WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#26067 closed defect (bug) (duplicate)

title problems when defining menu name same as one of my category

Reported by: shivam kumar Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Taxonomy Keywords: needs-codex
Focuses: Cc:

Description

When i define my primary menu name for eg: SOCIAL and by chance had to define the same name ie SOCIAL for one of my category in the same menu,it creates problem in displaying title for that particular category name,moreover when i tried to change the name of the primary menu it changed the name of the category itself resulting in page not found errors.
For eg: if i visit the other categories the title in browser window displays CATEGORY NAME(SEPARATOR)SITENAME that is "Category|Sitename"
But when i visit the category which is by chance similar in name to that of the primary menu which it falls under, it does not follows the same order to display titles as defined rather it just shows only the category name that is "CATEGORY" instead of "Category|Sitename"
Does that means we cant have a "category name" similar to that of the "primary menu name" which it falls under.Plus it changes the category permalink as well on changing the primary menu name.

Change History (1)

comment:1 SergeyBiryukov5 months ago

  • Keywords needs-testing needs-patch dev-feedback 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Version changed from 3.7.1 to 3.0

Duplicate of #5809, #16936, #20141, #20707.

Note: See TracTickets for help on using tickets.