Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#26080 closed defect (bug) (fixed)

Twenty Fourteen: only create new tag when saving Featured Content options in Customizer

Reported by: RDall Owned by: lancewillett
Milestone: 3.8 Priority: normal
Severity: normal Version: 3.8
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description (last modified by lancewillett)

In Twenty Fourteen I went into the Customizer and clicked into the Featured Content area.

  1. I started typing in the tag name and the field auto populated with the correct tag I was looking for. In this case November 11th.
  1. I then clicked on the tag and it populated the field. I then choose Save & Publish. But the tag name hadn't been applied.
  1. It only showed November in the field and didn't apply the images to the features area.
  1. So I tried a second time using the same procedure as above. With exactly the same results but this time it own showed Nov
  1. I knew something was wrong. So I check the tags screen and the November and Nov tags had been created but no posts had been applied to them. I deleted these extra tags.
  1. The November 11th tag still had all the posts.
  1. Wanting to crack this issue. I decided to try this process a third time. But instead of clicking the tag once it was populated in the featured content tag field I would click and then press the space bar and the slider showed the appropriate content.
  1. I then hit the Save & Publish and it worked.

So in summary:

Featured Content in customizer creates tags and doesn't apply content after proper tag has been clicked.

For those playing along at home:

WP 3.8-alpha-26127
Web Browser: Firefox 25.0

Attachments (1)

26080.diff (1.0 KB) - added by obenland 8 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
8 years ago

  • Milestone changed from Awaiting Review to 3.8

With exactly the same results but this time it own showed Nov

Confirmed. In my case, it displayed "nov" (lowercase).

#2 follow-up: @celloexpressions
8 years ago

Same issue as I mentioned at the end of #25549. Part of the issue is with the implementation of the suggest script (although it's critical to the feature's usability). We should be more careful about creating new tags too soon at least; perhaps we could only create the missing tag when publishing the customizer's changes.

#3 in reply to: ↑ 2 @lancewillett
8 years ago

  • Description modified (diff)
  • Summary changed from Twenty Fourteen: Feature Content Creates Tags in Customizer to Twenty Fourteen: only create new tag when saving Featured Content options in Customizer

Replying to celloexpressions:

perhaps we could only create the missing tag when publishing the customizer's changes.

Let's do that.

@obenland
8 years ago

#4 @obenland
8 years ago

There are actually two different bugs here:

  1. The form doesn't submit when the suggested term gets clicked.
  2. Tags are prematurely created.

26080.diff will fix the second, I'm looking into how we can improve the suggestions to trigger a submission.

#5 @obenland
8 years ago

  • Keywords has-patch added; needs-patch removed

#6 @obenland
8 years ago

Created #26110 with attached patch, to trigger form submission in the customizer.

#7 @lancewillett
8 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 26270:

Twenty Fourteen: avoid premature creation of tags when using the tag suggestion for Featured Content. Props obenland, fixes #26080.

Note: See TracTickets for help on using tickets.