WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#26084 closed defect (bug) (duplicate)

register_setting() calls filter: sanitize_option_{$option_name}, with wrong $accepted_args value.

Reported by: KingYes Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: Formatting Keywords:
Focuses: Cc:

Description

Hi guys.

When we use with register_setting() function, it's call to filter sanitize_option_{$option_name} with one $accepted_args.

I just think the filter "sanitize_option_{$option_name}", need to change the $accepted_args var to "2".

Because the apply_filters call with two params.

$value = apply_filters("sanitize_option_{$option}", $value, $option);

Attachments (1)

ticket-26084.diff (785 bytes) - added by KingYes 8 years ago.
ticket-26084.diff

Download all attachments as: .zip

Change History (3)

@KingYes
8 years ago

ticket-26084.diff

#1 @nacin
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15335.

#2 @SergeyBiryukov
7 years ago

  • Version changed from trunk to 3.7
Note: See TracTickets for help on using tickets.