WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#26085 closed defect (bug) (duplicate)

timeout in WP_Http_Streams::request unhandled

Reported by: thpani Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: HTTP API Keywords:
Focuses: Cc:

Description

WP_Http_Streams::request correctly calls stream_set_timeout().

However, from http://us2.php.net/stream_set_timeout it seems that stream_get_meta_data() has to be checked to see if a timeout actually occured during fread()

Tested using netcat as "slow" HTTP server:

while true; do (echo '1'; sleep 15; echo '2') | nc -l 8888 ; done

causes Wordpress to hang in this loop: http://core.trac.wordpress.org/browser/tags/3.7.1/src/wp-includes/class-http.php#L899

Change History (4)

#1 @thpani
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13841.

#2 @kpdesign
8 years ago

  • Milestone Awaiting Review deleted

#3 @SergeyBiryukov
8 years ago

  • Component changed from General to HTTP

#4 @SergeyBiryukov
8 years ago

  • Version changed from trunk to 3.7
Note: See TracTickets for help on using tickets.