WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#26118 closed defect (bug) (duplicate)

is_serialized() doesn't account for objects using PHP Serializable interface

Reported by: nerrad Owned by:
Milestone: Priority: normal
Severity: major Version: 3.7
Component: General Keywords: has-patch dev-feedback
Focuses: Cc:

Description

About Serializable -> http://us2.php.net/serializable

The problem: Serializable uses the token "C" at the beginning of the serialized string. This doesn't get recognized by Is_serialized() as a serialized string and thus doesn't get unserialized when maybe_unserialize is used.

The fix: Add the "C" token to the switch check in is_serialized().

See attached patch

Attachments (1)

26118.diff (374 bytes) - added by nerrad 8 years ago.
fix for is_serialized() to use "C" token

Download all attachments as: .zip

Change History (3)

@nerrad
8 years ago

fix for is_serialized() to use "C" token

#1 @dd32
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17375.

#2 @SergeyBiryukov
8 years ago

  • Version changed from trunk to 3.7
Note: See TracTickets for help on using tickets.