WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#26120 closed defect (bug) (fixed)

No visual indication of focus on checkbox for "Open link in new window/tab" in "Insert/edit link" dialog

Reported by: seanchayes Owned by: iammattthomas
Milestone: 3.8 Priority: normal
Severity: normal Version:
Component: Administration Keywords: ui-feedback has-patch
Focuses: ui Cc:

Description

Referring to ticket #25934
and
http://core.trac.wordpress.org/ticket/25934#comment:6
http://core.trac.wordpress.org/ticket/25934#comment:11

Following these steps:

  • Edit a post
  • Select text
  • Click Insert/Edit link button to create a link (or press alt+shift+a)
  • Press Tab twice to focus the "Open link in a new window/tab" checkbox

There is no visual cue that the focus is on the checkbox.

Suggest a CSS based patch to provide the visual cue.

Attachments (6)

26120.patch (381 bytes) - added by seanchayes 8 years ago.
insert-edit-chrome-no-focus-01.jpg (17.3 KB) - added by seanchayes 8 years ago.
insert-edit-firefox-no-focus-02.jpg (17.7 KB) - added by seanchayes 8 years ago.
insert-edit-firefox-focus-patch-03.jpg (18.4 KB) - added by seanchayes 8 years ago.
insert-edit-chrome-focus-patch-04.jpg (21.8 KB) - added by seanchayes 8 years ago.
26120.2.patch (375 bytes) - added by SergeyBiryukov 8 years ago.

Download all attachments as: .zip

Change History (10)

@seanchayes
8 years ago

#1 @seanchayes
8 years ago

  • Keywords has-patch added

#2 @seanchayes
8 years ago

Images to support this ticket:

Chrome on Windows


Firefox on Windows


#3 @SergeyBiryukov
8 years ago

  • Keywords ui-focus added
  • Milestone changed from Awaiting Review to 3.8

Tested in Firefox 25, Chrome 31, IE 8, IE 10, Opera 12, Opera 18.

Reproduced in Chrome, IE (both 8 and 10), and Opera 18. Could not reproduce in Firefox or Opera 12.

Can be reproduced with any checkbox (e.g. "Remember Me" on the login screen), not just that one.

Caused by outline: 0 for input[type="checkbox"], introduced in [26072]:
trunk/src/wp-admin/css/wp-admin.css?rev=26285#L267

I guess we can just remove that rule: 26120.2.patch.

#4 @iammattthomas
8 years ago

  • Owner set to iammattthomas
  • Resolution set to fixed
  • Status changed from new to closed

In 26289:

Cleanup on inputs:

  • Remove the !important from checkbox and radio border color
  • Remove the redundant #wpbody select rule
  • Add checkbox and radio inputs to the standard :focus style rules for inputs
  • Remove custom border and box shadow styles from .login inputs
  • Don't remove the default outline from select elements since webkit doesn't allow borders on selects

Fixes #26120.

Note: See TracTickets for help on using tickets.