WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#26123 closed defect (bug) (duplicate)

Duplicate content when appending a digit to URLs

Reported by: henrywright Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Canonical Keywords:
Focuses: Cc:
PR Number:

Description

When each of the URLs below are visited, the exact same content is displayed each time. Would search engines see this a duplicate content?

example.com/support/
example.com/support/2/ 
example.com/support/3/ 
example.com/support/4/ 
example.com/support/5/

Note that when I visit a page such as example.com/support/kyathhaggfa where kyathhaggfa is garbage, I get a 404 page. This is the behaviour I would expect to see when a digit is appended to a page or post URL.

Interestingly, I don't see the issue happening on tag pages such as the following:

example.com/tags/soccer/
example.com/tags/soccer/2/
example.com/tags/soccer/3/

This issue was originally raised at BuddyPress Trac but further investigation has revealed it to be happening on WordPress too.

BP Trac ticket:
http://buddypress.trac.wordpress.org/ticket/5224

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11694, #21278, and #21464.

Note: See TracTickets for help on using tickets.